Database Latency
Incident Report for AutoPal Software
Resolved
This has been resolved - without any outages.

Regards,
Posted Nov 16, 2017 - 13:04 MST
Identified
AutoPal is experiencing some latency in accessing some of the database tables. We are investigating this issue.
Posted Nov 16, 2017 - 10:23 MST