Regional Outage
Incident Report for AutoPal Software
Resolved
This incident has been resolved.
Posted Jun 09, 2019 - 09:20 MDT
Investigating
AutoPal is investigating a regional outage that is affecting some customers. Updates will be posted as we learn more.
Posted Jun 09, 2019 - 09:09 MDT
This incident affected: AutoPal Software Web App.